This project is read-only.
Application Installation

Before attempting to run the application, please make sure you have the following pre-requisites:

1) Microsoft .Net Framework 3.5. You can download Microsoft .Net Framework 3.5 here.

Running the Application

1) Download the application binaries from the Downloads tab of this project.

2) Extract the binaries to any folder of your choice.

3) Run the application (Mini Compiler.exe)

Compiling the Source Code

Before attempting to compile the source, please make sure you have the following pre-requisites:

Build Requirements

1a) Visual Studio 2008/2010 or Visual C# Express 2008/2010. You can find these here.
or
1b) SharpDevelop 3.2. You can find SharpDevelop here.

2) Download the Mini Compiler sources from the Source Code tab of this project and extract them to a folder of your choice.

3) Download the open source ICSharpCode.TextEditor library, which is part of the SharpDevelop 3.2 IDE and add the 'ICSharpCode.TextEditor.dll' file as a Reference to the project. The following screen shot shows an example project release folder.

mini_compiler_project_folder.png

4) Build the project.

Last edited Nov 12, 2010 at 11:23 PM by Crianthis, version 4

Comments

No comments yet.